Öppna huvudmenyn

Lightburn

LightBurn är programvaran som används för att styra Redsail Lasern

Innehåll

Manual

Handhavande

Steg-för-steg

  • Skapa din fil. Du kan antigen rita i valfritt vektorprogram, tex Inkscape eller Illustrator. För mer avancerade modeller kan det vara enklare att 3D modellera i CAD och sedan exportera sidorna som DXF eller annat vektorformat.
  • Importera din fil. LightBurn klarar av att läsa in flera olika format, bland annat DXF, AI (version 8 eller senare) och SVG.
  • Dela ut färger till olika linjer. Varje färg kan ha olika inställningar.

LightBurns kontrollpanel

  • Under "Cuts and Layers" kontrollerar du parametrna för varje lager/färg.
  • Origin i LightBurn kontrolleras av "Start From:" och "Job Origin". "Start From" kontrollerar vart på maskinens bädd som jobbet kommer att starta. "Job Origin" kontrollerar vart origin är i din fil
  • "[]Frame" och "()Frame" knapparna i kontrollpanelen får laserhuvudet att röra sig i en outline runt det du vill skära. "[]Frame" gör en rektangel som innefattar alla objekten medan "()Frame" följer den yttersta konturen av objekten.

Egen dator

OBS: LightBurn kräver licens men kan köpas med 75% rabatt via Stockholm Makerspace via vår medlemssida.

Du kan installera programmet och köra från din egen dator, lasern kan styras om man är ansluten på lokalens nätverk. Installation görs enligt manualen: https://lightburnsoftware.github.io/NewDocs/Installation.html

LightBurn inställningar

Du kan antingen följa instruktionerna nedan, dock inkluderar det ej gravyr inställningarna, eller importera följade fil, redsail.lbdev, till LightBurn. Filen på github inkluderar gravyr inställningarna. Alternativt kan man importera scanning_offsets.lbso med bara gravyr inställningarna. Gravyr offsetsen och alternativet för att importera det finns under menyn edit, sen device settings.

1. Öppna Devices i Lightburn. Klicka sedan på Create Manually, alternativt Import om du har laddat ner .lbdev filen. 2. Välj Ruida 3. Välj Ethernet/UDP 4. Knappa in IP-adressen 10.20.0.252
OBS: Programmet hanterar punkterna konstigt
5. Döp den till något vettigt, t.ex. RedSailLaser 6. Välj Rear Right som origin 7. Tryck Finish 8. Nu ska det gå att välja laserskäraren bland devices:

Adobe Illustrator

  • Skapa nytt dokument med bredd 1400mm, längd 900mm, orientering liggande och färgläge RGB. Storleken är bara max för Laserskäraren. Välj vad du vill.
  • Ändra till mm i "Arkiv > Dokumentformat" (File > Document setup)
  • Exportera filen som DXF, SVG eller vanliga adobe formatet(ai). För ai formatet så kommer LightBurn att använda outlinesen ifrån filen.

DXF Exportering i Illustrator

Exportera som DXF-fil genom att välja "Arkiv > Exportera > Exportera som" (File > Export > Export as) med Autocad Version: R14/LT98/LT97 och Skala 1 mm = 1 Enhet (Scale 1mm = 1 unit)

Tips: DXF-filerna har stöd för färgade banor. Sätter du olika färger på banorna i Illustrator så kommer dessa med när du exporterar till Autolaser. I Autolaser är det sedan möjlighet att justera skär/gravyr-styrka för specifika färger.

DXF import i Autolaser kan ibland ha problem med att gruppera objekt. Ett Javascript som löser detta hittar du här: https://forums.adobe.com/thread/456042